This is a read-only archive. Find the latest Linux articles, documentation, and answers at the new!

Filing US federal taxes under Linux

Posted by: Anonymous [ip:] on March 27, 2008 07:59 PM
I filed with TurboTax last year and this year and whereas last year I ran into the dreaded, but useless "Your browser version is unsupported" message, (worked fine), this year I didn't have any such warnings. I have no idea why I didn't as obviously others did have this problem. For me the experience has only been better this year as opposed to last. I used FF- on SabayonLinux-3.5.


Return to Filing US federal taxes under Linux