This is a read-only archive. Find the latest Linux articles, documentation, and answers at the new Linux.com!

Linux.com

Re:I Dislike This Versioning Issue

Posted by: Anonymous Coward on May 09, 2007 07:44 PM
It should be no surprise that installing new software may require installing new software.

Rather than “miserably” installing from source, one can patiently wait until one has the next Ubuntu (or whatever) release installed, with the needed library versions.

Software projects I've been in have made some attempt to avoid depending on too recent versions of software. Though there are tradeoffs to weigh up.

I think the most important thing for reducing such “misery” is to make it clear what the dependencies are (giving an appropriate error message), and to work on making it easy for people to upgrade to the newest versions of libraries.

#

Return to Metasploit 3.0 doesn't pwn systems, black hats pwn systems